"Something totally unexpected happened" error

  • strict warning: Only variables should be passed by reference in /var/sites/e/enterpriseios.com/public_html/sites/all/modules/contrib/captcha/captcha.inc on line 61.
  • strict warning: Only variables should be passed by reference in /var/sites/e/enterpriseios.com/public_html/sites/all/modules/contrib/captcha/captcha.inc on line 61.
  • strict warning: Only variables should be passed by reference in /var/sites/e/enterpriseios.com/public_html/sites/all/modules/contrib/captcha/captcha.inc on line 61.
  • strict warning: Only variables should be passed by reference in /var/sites/e/enterpriseios.com/public_html/sites/all/modules/contrib/captcha/captcha.inc on line 61.
  • strict warning: Only variables should be passed by reference in /var/sites/e/enterpriseios.com/public_html/sites/all/modules/contrib/captcha/captcha.inc on line 61.
  • strict warning: Only variables should be passed by reference in /var/sites/e/enterpriseios.com/public_html/sites/all/modules/contrib/captcha/captcha.inc on line 61.
  • strict warning: Only variables should be passed by reference in /var/sites/e/enterpriseios.com/public_html/sites/all/modules/contrib/captcha/captcha.inc on line 61.
  • strict warning: Declaration of views_handler_field_user_name::init() should be compatible with views_handler_field_user::init(&$view, $data) in /var/sites/e/enterpriseios.com/public_html/sites/all/modules/contrib/views/modules/user/views_handler_field_user_name.inc on line 61.
pvpacharterschool's picture

pvpacharterschool

Joined: Nov 1, 2013
WWW
No votes yet

Thanks for writing this script !!

I downloaded your Constructed Setup Process and I have 50 Apple ID's in a .csv file. When I drag the .csv file to the Constructed Setup Process droplet, I get:

"Woops! Something totally unexpected happened while trying to run in interactive mode

File OS 10.8:Users:tech:Desktop:HPS Apple ID Setup Process - Interactive.app:Contents:Resources: wasn't found."

(error dialog screenshot attached)

So, looks like there is a hard-coded path somewhere in one of the scripts that should be replaced with the real path to my Apple ID Automation Builder app? I looked in all the package contents and couldn't find it.

I tried renaming my hard drive 'OS 10.8" and creating that path as a symlink to /real/path/to/Constructed Setup Process.app/Contents/Resources but that didn't work either.

And, "...:Contents:Resources:" is a folder not a file, so maybe that's the issue ... but I don't know where to look to fix that, if I go in there and start messing around I'll only cause more damage.

I'm running iTunes 10.6.3 on OS 10.8.5, in case that matters

thanks!

Top
Eight_Quarter_Bit's picture

Eight_Quarter_Bit

Joined: Jan 27, 2012

Hm, that's a new one.

Your rating: None

Hm, that's a new one.

Yea, that path is supposed to dynamically update itself. As a matter of fact, it's the very first two lines of code in the constructed process. Are you running the constructed setup process from a read-only volume? Did you move it out of the .dmg onto your local hard disk?

I move processes between machines all the time (as a matter of fact the path you are seeing there is one of my VMs. I don't recommend running the process in a VM, by the way. I find Applescripts that are heavy on UI scripting have a tendency to crash the Applescript bytecode interpreter when run in a virtual machine, for unknown reasons.) and I've never seen it fail to update the path to itself.

If it is on a read/write volume, you might try checking the permissions on the app bundle. Right-click on it, "get info", make sure your user is owner and has read/write/execute permissions, and then apply to enclosed items.

Top
Eight_Quarter_Bit's picture

Eight_Quarter_Bit

Joined: Jan 27, 2012

Another possibility...

Your rating: None

Ah! I also realized the path global variable isn't being updated when run via the "on open" handler (which is what is called when you drop files on the script.) Every other global variable is either not updated at all, or updated by the main handler (which is run when dropping files on the script.) The path variable isn't updated by the main handler, it's updated at the top of the script, which doesn't get run when you drop files on the app bundle. I missed this in testing, because if the script is launched on double-click once and then the path to the constructed process doesn't change, it will function correctly with file drops (the global variable is persistent across runs.)

Try launching the constructed process via double-click. That should update the path. From then on out it should function on file drop or via double-click, as long as the process isn't moved. If you move it, just launch it on double-click again. That's a bug I will have to correct.

Top
pvpacharterschool's picture

pvpacharterschool

Joined: Oct 31, 2013
WWW

thanks, will try again

Your rating: None

thanks, will try again tomorrow!

Top
pvpacharterschool's picture

pvpacharterschool

Joined: Oct 31, 2013
WWW

now it runs, but ID creation fails

Your rating: None

It runs by double-click, but account creation fails - the 'failure reason' field in the Failed Accounts .csv file says:
Always Perform This Action: Click Button ''Free

(that's all it says - looks like something is getting truncated)

Top
pvpacharterschool's picture

pvpacharterschool

Joined: Oct 31, 2013
WWW

now a different error

Your rating: None

I set up a new CSV file using the headers exported from the constructed process. Same issue, but now iTunes gives me "unknown error 12002" in addition.

Top
pvpacharterschool's picture

pvpacharterschool

Joined: Oct 31, 2013
WWW

live session?

Your rating: None

I don't suppose you ever do live screen sharing sessions via join.me or anything like that?

Top

Who is online?

There are currently 0 admins, 0 users and 80 guests online. Connected users: .

Recent Activity